Polygon Mainnet Degraded Performance

Incident Report for Alchemy

Resolved

Polygon has successfully stabilized the network following deployment of an upstream fix. Block production and finality are now progressing as expected and reorganization risk has returned to expected baseline levels.

All Alchemy Polygon Mainnet services are now operating normally!
Posted Dec 18, 2025 - 01:07 UTC

Identified

Polygon has introduced a fix intended to stabilize the network. We are actively validating these changes through our systems. As mitigation takes effect, customers may see incremental improvements, though intermittent impact is still possible until full stabilization is confirmed.
Posted Dec 17, 2025 - 23:27 UTC

Update

This incident is also being actively tracked on Polygon’s official status page, where additional updates may be published as they become available: https://status.polygon.technology/incidents/9ysh9zczb8ml
Posted Dec 17, 2025 - 18:47 UTC

Investigating

We are currently investigating degraded performance affecting Polygon Mainnet. A subset of nodes appears to be stalled, and early indicators suggest a broader, chain-wide issue. We are actively coordinating with the Polygon team and will provide updates as more information becomes available.
Posted Dec 17, 2025 - 18:42 UTC
This incident affected: Polygon.