Monad Testnet Instability Issues

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Mar 17, 2025 - 13:20 UTC

Update

Incident has been resolved.
Posted Mar 17, 2025 - 13:12 UTC

Monitoring

A patch released by the Monad team has been deployed to our nodes. This, along with additional node resources coming online, has significantly improved our latency figures back to expected baselines. We will continue to monitor.
Posted Mar 15, 2025 - 20:10 UTC

Investigating

We are currently investigating some instability on Monad that can lead to high response time.
We'll update this page alongside our findings! Thanks for your patience!
Posted Mar 13, 2025 - 13:15 UTC
This incident affected: Monad.