Elevated Latency and Errors for Token Balances & Portfolio API

Incident Report for Alchemy

Resolved

This incident has been resolved. We’re seeing latency and error rates return to normal.
Posted Feb 18, 2026 - 17:13 UTC

Monitoring

A fix has been implemented and we are continuing to monitor.
Posted Feb 18, 2026 - 17:12 UTC

Update

We are continuing to investigate this issue.
Posted Feb 18, 2026 - 16:57 UTC

Investigating

We are currently investigating elevated latency and increased error rates affecting the Token Balances API and Portfolio API. We are mainly seeing impact on Base Mainnet.
Posted Feb 18, 2026 - 16:49 UTC
This incident affected: Base.