Elevated Latency on Tempo Moderato

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Jul 15, 2026 - 16:50 UTC

Update

We are continuing to investigate this issue.
Posted Jul 15, 2026 - 16:50 UTC

Investigating

We're seeing increased latency and higher block times on Tempo Testnet. This is caused by a planned stress test run by the Tempo network team, not by Alchemy infrastructure. The test window is expected to last up to 2 hours starting 2PM UTC on July 15. Performance should recover once the test concludes. No action is required on your end.
Posted Jul 15, 2026 - 13:17 UTC
This incident affected: Tempo.