Network Halt on Flow

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Dec 30, 2025 - 12:13 UTC

Investigating

We are currently experiencing service interruptions on Flow caused by an upstream issue with the Flow network. The Flow Foundation is investigating a potential security incident and has temporarily halted the network as a precaution to protect user assets.

The Flow Foundation is actively working with network partners and relevant authorities to resolve the issue.

For official Flow Network updates, please monitor: https://status.flow.com/incidents/h42fpxdyksjj
Posted Dec 27, 2025 - 18:21 UTC
This incident affected: Flow.