Rise Testnet Service Degradation

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Jan 11, 2026 - 21:14 UTC

Monitoring

The impacted nodes are recovering, and we’re starting to seeing performance stabilize.
Posted Jan 11, 2026 - 18:50 UTC

Identified

The issue has been identified.
Posted Jan 11, 2026 - 18:49 UTC

Investigating

We are currently aware of an issue impacting Rise Testnet and are actively investigating with the Rise core team.
Posted Jan 11, 2026 - 18:34 UTC