[Network-Wide] Fraxtal Hoodi Testnet Stall

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted May 11, 2026 - 17:23 UTC

Update

We are continuing to investigate this issue.
Posted May 11, 2026 - 17:19 UTC

Investigating

We are currently investigating a network-wide Fraxtal Hoodi Testnet stall at block 9029148.
Posted May 11, 2026 - 17:15 UTC
This incident affected: Fraxtal.