Rise Testnet Stall

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Apr 18, 2026 - 01:50 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 17, 2026 - 21:55 UTC

Update

We’ve been in touch with the Rise Testnet team, who have confirmed the network is currently experiencing elevated load over the past few days. This increased demand is contributing to the current degradation in network performance.

We are actively working with the chain provider to further investigate and troubleshoot the issue. We’ll continue to share updates here as more information becomes available.
Posted Apr 17, 2026 - 20:40 UTC

Investigating

We are currently investigating this issue.
Posted Apr 17, 2026 - 17:33 UTC
This incident affected: Rise.