Ink Sepolia EUC1 Downgraded Performance

Incident Report for Alchemy

Update

We are continuing to investigate this issue.
Posted Apr 03, 2026 - 14:40 UTC

Update

We are currently investigating degraded performance on Ink Sepolia. Customers might experience elevated 503 error rates and latency.
Posted Apr 03, 2026 - 12:45 UTC

Investigating

We are currently investigating this issue.
Posted Apr 03, 2026 - 12:30 UTC
This incident affects: Ink Chain.