Payment System Degradation
Incident Report for Alchemy
Resolved
Full functionality has been restored. All users should now be able to sign up for accounts and edit billing details.
Posted Apr 04, 2023 - 01:08 UTC
Investigating
Due to an issue with our payment processor, new user account creation via alchemy.com will currently fail with the error message "Failed to confirm payment." Certain payments functions (such as invoices and card details in the dashboard) are also currently suspended.
Posted Apr 03, 2023 - 23:17 UTC
This incident affected: Website Status.