[Network-Wide] Polygon Amoy Stall

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted May 08, 2026 - 08:32 UTC

Update

This stall was confirmed to be a network wide load test from the Polygon team. This test ended and the chain has since resumed advancing with no issues.
Posted May 07, 2026 - 23:53 UTC

Investigating

We are currently investigating a Polygon Amoy stall at block 37973078 (0x2436c56). This is a network-wide stall. We are in touch with the Polygon team and will update the status page as soon as we have more information.
Posted May 07, 2026 - 21:02 UTC
This incident affected: Polygon.