Abstract Mainnet Degraded Performance

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Mar 19, 2026 - 20:35 UTC

Investigating

We are currently investigating an issue affecting Abstract mainnet. The last confirmed block is 46887372. Customers may experience degraded performance or failures across all Abstract mainnet services, including JSON-RPC requests and other dependent functionality.

This appears to be a chain-wide issue. We are actively monitoring the situation and working to restore full service.
Posted Mar 19, 2026 - 20:26 UTC
This incident affected: Abstract.