Settlus Sepolia Testnet - Degraded Performance

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted May 01, 2026 - 11:40 UTC

Identified

We are currently experiencing a chain stall on the Settlus Sepolia testnet. We have pushed a fix and the nodes are currently re-syncing from a snapshot. This is expected to take a few hours. We will provide updates as the sync progresses.
Posted Apr 30, 2026 - 13:02 UTC
This incident affected: Settlus.