getLogs Degraded Performance For Networks With Unlimited Block Range

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Jun 22, 2026 - 15:58 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 22, 2026 - 15:31 UTC

Update

We are continuing to investigate this issue.
Posted Jun 22, 2026 - 15:09 UTC

Investigating

We’re currently investigating an issue affecting eth_getLogs performance on networks with unlimited block ranges. Customers may see intermittent errors or increased latency, but this only affects blocks very close to the chain tip.
Posted Jun 22, 2026 - 13:27 UTC