Ink Sepolia Safe/Finalized Block Heads Stalled

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted May 20, 2026 - 10:33 UTC

Monitoring

The Ink team has applied a fix, and we are monitoring the results.
Posted May 20, 2026 - 09:48 UTC

Investigating

We are investigating an issue for safe and finalized tags on Ink Sepolia, which returning stalled block heads. The "finalized" block is currently stalled at block 50232683. This appears to be a network-wide issue affecting other providers, not isolated to Alchemy. We are monitoring for updates from the Ink team and will provide further information as it becomes available.
Posted May 20, 2026 - 08:30 UTC
This incident affected: Ink Chain.