Mantle Sepolia network stall

Incident Report for Alchemy

Resolved

Mantle Sepolia is back in sync!
Posted Mar 06, 2025 - 16:10 UTC

Investigating

Mantle Sepolia network experienced a stall due to the Pectra hard fork. The sequencer appears to be stuck, with the latest block being 4 hours old.
We’re in touch with the Mantle team for further updates and we'll share update!
Posted Mar 05, 2025 - 19:05 UTC
This incident affected: Mantle.