Latency observed across multiple networks

Incident Report for Alchemy

Resolved

This incident has been resolved.

Starting at 07:54 UTC a Cloudflare maintenance event caused high latency figures across multiple networks and methods. This incident has been resolved as of 09:37UTC.
Posted Apr 29, 2025 - 10:23 UTC

Monitoring

Latency metrics have stabilized, we're continuing to monitor the situation.
Posted Apr 29, 2025 - 10:14 UTC

Identified

We are beginning to see a recovery in latency figures across networks. We are continuing to investigate.
Posted Apr 29, 2025 - 09:44 UTC

Investigating

We are actively investigating elevated latency across multiple methods and networks.
Posted Apr 29, 2025 - 09:05 UTC