Elevated Latencies For EU Region

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Aug 06, 2025 - 15:41 UTC

Monitoring

Our provider has recovered our servers in the EU region, and we're awaiting a full root cause analysis from them before moving traffic back to that region.

We'll continue to serve from our US + Asia stacks until we receive a RCA.
Posted Aug 05, 2025 - 23:30 UTC

Investigating

Due to an issue with an infra provider, we're seeing increased latencies for requests hitting our EU stack. We're working closely with our provider, as they resolve this issue on their end!
Posted Aug 05, 2025 - 20:46 UTC
This incident affected: Ethereum, Abstract, Animechain, Arbitrum, Arbitrum Nova, ApeChain, Astar, Avalanche C Chain, Base, Berachain, Blast, BNB Smart Chain, Celo, CrossFi, Degen, Fantom, Flow, Fraxtal, Geist, Gnosis, Ink Chain, Kinto, Lens, Linea, Lumia, Mantle, Metis, Monad, opBNB, Optimism, Polygon, Polygon zkEVM, Polynomial, Ronin, Rootstock, Scroll, SEI, Settlus, Shape, Solana, Soneium, Sonic, Starknet, Story, Superseed, Unichain, Validator, World Chain, XMTP, Zetachain, ZKsync, Zora, and Alchemy Dashboard.