Elevated Latency in EUC1 & APSE1

Incident Report for Alchemy

Resolved

Resolved – EUC1 & APSE1 Latency Issue
Traffic has been routed back to EUC1 and APSE1, and the underlying issue has been fully resolved. RPCs are operating normally, and latency is back to expected levels for all regions.

Current status: Resolved
Posted Aug 15, 2025 - 02:12 UTC

Update

Update – Slightly Higher Latency for EUC1 & APSE1
We’re still routing traffic from EUC1 and APSE1 to USE1 and USW2 while we work on the underlying issue. RPCs are fully usable, and latency is now about the same as baseline — only slightly higher for users in Asia and Europe. We’ll keep this routing in place until the fix is complete.

Current status: Mitigation in Place – Work Ongoing
Posted Aug 15, 2025 - 01:40 UTC

Monitoring

Update – Traffic Rerouted for EUC1 & APSE1
We have rerouted traffic from EUC1 and APSE1 to USE1 and USW2 to help mitigate the latency issues. Until the underlying issue is fully resolved, you may still experience slight latency for requests previously served from EUC1 and APSE1. Our team continues to work on a permanent fix.
Posted Aug 15, 2025 - 01:02 UTC

Identified

We are currently investigating reports of increased latency affecting services on all network in the EUC1 (Europe Central) and APSE1 (Asia Pacific Southeast) regions. Our engineering team is working to identify the cause and mitigate impact. We will provide updates as soon as more information is available.
Posted Aug 15, 2025 - 00:14 UTC