Solana gRPC - degraded performance in US East

Incident Report for Alchemy

Resolved

This incident has been resolved. The root cause was a service crash on our replay mechanism. This issue has been patched and functionality has been completely restored
Posted Jun 20, 2026 - 16:07 UTC

Investigating

We are investigating a potential outage on our Solana gRPC service in US-East 1 region. We are re-routing gRPC connections to other regions to stabilize service. Users located in US-East may see delays in payload delivery following this. We are investigating for a route cause and will have more details shortly.
Posted Jun 20, 2026 - 01:10 UTC
This incident affected: Solana.