[Network-Wide] Polygon ZKEVM Block Production Stalled

Incident Report for Alchemy

Resolved

Block production resolved on Polygon ZKEVM
Posted Aug 22, 2025 - 16:23 UTC

Investigating

Polygon ZKEVM is currently experiencing a stall block production. The latest block produced was 24940457: https://zkevm.polygonscan.com/
Posted Aug 22, 2025 - 14:57 UTC
This incident affected: Polygon zkEVM.