Sei Testnet Degraded Performance

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Feb 22, 2026 - 13:09 UTC

Investigating

We are currently investigating elevated latency and node stability issues on Sei Testnet. The impact is primarily affecting eth_call requests and other RPC methods. Our team will provide updates as we learn more.
Posted Feb 22, 2026 - 11:07 UTC
This incident affected: SEI.