Elevated Latency and Block Lag

Incident Report for Alchemy

Resolved

The upstream feed relay instabilities have been resolved, and latency and block lag have returned to normal.
Posted Sep 04, 2026 - 17:28 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 04, 2026 - 16:54 UTC

Update

We are investigating elevated latency and block lag affecting a subset of requests due to upstream feed relay instabilities. Our team is actively working to restore normal performance and will provide an update soon.
Posted Sep 04, 2026 - 16:23 UTC

Investigating

We are investigating elevated latency and block lag affecting a subset of requests. Our team is actively working to restore normal performance and will provide an update soon.
Posted Sep 04, 2026 - 16:22 UTC