[Network Wide] Celo Sepolia Network Stalled

Incident Report for Alchemy

Resolved

Incident is resolved: block are being produced again!
Posted Jun 23, 2026 - 22:42 UTC

Investigating

We're encountering a network wide incident on Celo Sepolia. Last block produced 28967846: https://sepolia.celoscan.io/block/28967846
Posted Jun 23, 2026 - 22:12 UTC
This incident affected: Celo.