[Network Wide] Corn Testnet

Incident Report for Alchemy

Resolved

Block production on Corn Testnet has resumed and the network is operating normally. The testnet experienced a chain stall from approximately 09:45 to 16:30 UTC on May 24, 2026.
Posted May 24, 2026 - 16:30 UTC

Investigating

We are aware that block production on Corn Testnet has stalled. Last block was produced was 5,648,881. Transactions are not being processed at this time.
Posted May 24, 2026 - 09:45 UTC