Fraxtal Mainnet USE1 Degraded Performance

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Mar 30, 2026 - 09:01 UTC

Investigating

We are currently investigating this issue, customers may experience elevated latency.
Posted Mar 27, 2026 - 17:42 UTC
This incident affected: Fraxtal.