Robinhood Mainnet - Delayed User Operation Inclusion Times

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Jul 13, 2026 - 21:13 UTC

Investigating

We are actively investigating an issue affecting Robinhood Mainnet where there are delayed user operation inclusion times.
Posted Jul 13, 2026 - 21:09 UTC
This incident affected: Robinhood.