Op Sepolia Network Not Updating to the Latest Block
Incident Report for Alchemy
Resolved
This incident has been resolved.
Posted Jun 04, 2024 - 20:26 UTC
Investigating
Nodes on the current network have fallen behind the latest block number, and may return outdated block information. We're looking into the issue now and will provide an update ASAP!
Posted Jun 04, 2024 - 17:26 UTC