[Network-Wide] Sonic Mainnet stalled

Incident Report for Alchemy

Update

Several nodes in our primary fleet have successfully resynced and are now serving traffic. However, we are not yet back to full capacity; customers may experience elevated latency or an intermittent error rate. We will provide a final update once all nodes are fully back online
Posted Mar 26, 2026 - 16:30 UTC

Update

Our Sonic mainnet RPC nodes are continuing to resync from the latest snapshot. During this process, all traffic is being routed through secondary infrastructure with updated binaries. Websocket connections are unavailable until the resync is complete, and customers may experience elevated latency or intermittent errors on RPC requests.

We expect the resync to finish within the next several hours and will provide another update once primary nodes are back online and operating at full capacity.
Posted Mar 26, 2026 - 00:00 UTC

Update

An accidental hard fork occurred on the Sonic mainnet due to a consensus-breaking change introduced in Sonic client v2.1.6, related to an upgraded Ethereum library containing CVE security patches. Nodes running older client versions fell out of consensus at block 66,026,364, while the network itself continued producing blocks normally.

Our Sonic mainnet RPC nodes were affected. We have upgraded all nodes to v2.1.6 and initiated a full database resync from the latest snapshot. In the interim, traffic is being served through secondary infrastructure with updated binaries. Customers may experience intermittent errors or elevated latencies until primary nodes complete the resync process.

The Sonic network remains fully operational -- blocks continue to be produced, transactions are processing, and funds are safe.
Posted Mar 25, 2026 - 13:40 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 25, 2026 - 12:18 UTC

Investigating

We are currently investigating this issue.
Posted Mar 25, 2026 - 10:16 UTC
This incident affects: Sonic.