Robinhood Mainnet - Elevated Latency in Asia Pacific

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Jul 24, 2026 - 11:09 UTC

Investigating

A subset of requests on Robinhood Mainnet routed through our Asia Pacific region may be experiencing increased latency.
Posted Jul 23, 2026 - 15:12 UTC
This incident affected: Robinhood.