Elevated Latencies in the USE1 Region

Incident Report for Alchemy

Resolved

Between 18:42 and 18:57 UTC on Sep 29, we observed a spike in latency impacting multiple networks in the USE1 region. The issue has since been resolved and traffic is back to normal levels!
Posted Sep 29, 2025 - 19:34 UTC

Update

We are continuing to investigate this issue.
Posted Sep 29, 2025 - 18:56 UTC

Investigating

We're currently encountering latencies in USE1 Region. We're actively investigating with our eng team - we'll keep this page updated alongside our findings
Posted Sep 29, 2025 - 18:56 UTC
This incident affected: US East.