Elevated Latency for Solana Mainnet

Incident Report for Alchemy

Monitoring

A routing change has been implemented, and we are observing latency returning to normal levels.
Posted Sep 11, 2026 - 09:02 UTC

Investigating

We are investigating elevated latency affecting getSignaturesForAddress requests on Solana Mainnet in the US East region.
Posted Sep 11, 2026 - 08:43 UTC
This incident affects: Solana.