Arbitrum Network Congestion
Incident Report for Alchemy
Resolved
This incident has been resolved.
Posted Mar 23, 2023 - 17:14 UTC
Investigating
The Arbitrum network is currently undergoing high network congestion due to its token airdrop. The team is investigating an working to mitigate the effect.
Posted Mar 23, 2023 - 13:22 UTC
This incident affected: Arbitrum Mainnet (JSON-RPC Request API).