[Cloudflare-Incident] Increased latencies across RPC, Subgraphs, Wallet-Services and eAPIs

Incident Report for Alchemy

Resolved

The elevated latencies and timeouts impacting Alchemy services have now been resolved.

The root cause was a Cloudflare network performance incident in the US-East-1 (Ashburn) region. Cloudflare implemented mitigations, and our monitoring confirms that traffic and latency levels have returned to normal. See cloudflare status page: https://www.cloudflarestatus.com/incidents/d9n3g1vnxdd2

All products - including RPC, Subgraphs, Wallet Services and eAPIs - are now fully stable!

Thank you for your patience while we worked closely with Cloudflare to resolve this issue 🙏
Posted Aug 21, 2025 - 20:47 UTC

Monitoring

Cloudflare has identified the root cause of the network performance issues in the US-East-1 (Ashburn) region and is actively implementing a fix. They’ve started making manual traffic adjustments and are monitoring for improvement: https://www.cloudflarestatus.com/incidents/d9n3g1vnxdd2

We’ll provide another update as soon as we confirm stabilization!
Posted Aug 21, 2025 - 19:15 UTC

Identified

We are currently experiencing elevated request latencies and timeouts across multiple Alchemy products (RPC, Subgraphs, Wallet-Services and eAPIs).

The issue is tied to an ongoing Cloudflare network incident in the US-East-1 (Ashburn) region: https://www.cloudflarestatus.com/incidents/d9n3g1vnxdd2
Posted Aug 21, 2025 - 18:19 UTC

Investigating

We're currently seeing increased latencies with third party providers, we're investigating and we'll keep this page updated
Posted Aug 21, 2025 - 17:39 UTC