Ethereum Mainnet - Elevated Data API Latencies

Incident Report for Alchemy

Resolved

The elevated latencies affecting Ethereum Mainnet Data APIs have been resolved.
Posted Aug 29, 2026 - 19:45 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 29, 2026 - 18:20 UTC

Investigating

A subset of requests on Ethereum Mainnet are experiencing elevated latency.
Posted Aug 29, 2026 - 18:13 UTC
This incident affected: Ethereum.