Due to a network wide issue we are seeing degraded performance on Polygon zkEvm

Incident Report for Alchemy

Resolved

This Incident has been resolved
Posted Mar 17, 2025 - 16:06 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 17, 2025 - 13:16 UTC
This incident affected: Polygon zkEVM.