Cronos Mainnet - Degraded performance

Incident Report for Alchemy

Resolved

Nodes have been rescyned with stable binary and services are back to healthy.
Posted Jul 24, 2026 - 12:49 UTC

Identified

A part of our Cronos nodes were down due to a binary issue.
Posted Jul 24, 2026 - 12:48 UTC

Update

We are continuing to investigate this issue.
Posted Jul 24, 2026 - 09:36 UTC

Investigating

A subset of requests on Cronos Mainnet are experiencing availability issues.
Posted Jul 24, 2026 - 09:36 UTC
This incident affected: Cronos.