Resolved: Elevated latency on Polygon Mainnet

Incident Report for Alchemy

Resolved

Between approximately 23:20 UTC on July 17 and 03:30 UTC on July 18, some Polygon Mainnet requests experienced slower than normal response times, mainly for log queries. The issue was limited to the us-east-1 region.
The cause was an unusually heavy request load that put pressure on part of our infrastructure in the region. We added extra capacity and rebalanced traffic, after which performance returned to normal.

The issue is fully resolved. We apologize for the disruption.
Posted Jul 17, 2026 - 20:00 UTC