Elevated Latency Across Multiple Regions and Chains

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Feb 18, 2026 - 17:34 UTC

Monitoring

A fix has been deployed and we are actively monitoring the results. Latency should be returning to normal across all affected regions.
Posted Feb 18, 2026 - 17:14 UTC

Investigating

We are currently investigating elevated latency affecting API requests across multiple regions and chains. Some requests may experience slower than normal response times or increased timeouts.

Our engineering team has been alerted and is actively investigating the root cause. We will provide updates as more information becomes available.

We apologize for any disruption this may cause and appreciate your patience.
Posted Feb 18, 2026 - 17:03 UTC
This incident affected: US East, EU Central, US West, and AP SE.