[Network Wide] Cronos Mainnet Halted

Incident Report for Alchemy

Resolved

Incident is resolved and blocks are being produced again - confirmed by Cronost team: https://x.com/CronosNetwork/status/2094417832394301499
Posted Aug 31, 2026 - 13:38 UTC

Investigating

Network wide incident is affecting Cronos Mainnet and block production has been halted: https://x.com/CronosNetwork/status/2094072333434769703
Posted Aug 31, 2026 - 12:15 UTC
This incident affected: Cronos.