Rise Testnet Service Degradation

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Jan 05, 2026 - 17:48 UTC

Investigating

We are currently aware of an issue impacting Rise Testnet and are actively investigating with the Rise core team. The issue appears to be chain-wide.

For Rise Network updates, please monitor: https://status.testnet.risechain.com/
Posted Jan 05, 2026 - 14:40 UTC