Elevated Errors on World Chain

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Sep 16, 2025 - 00:50 UTC

Investigating

We are currently investigating elevated errors on world chain related to our open incident on Ethereum mainnet.
Posted Sep 16, 2025 - 00:21 UTC
This incident affected: World Chain.