Degraded Performance on Arbitrum Sepolia
Incident Report for Alchemy
Resolved
This incident has been resolved.
Posted Jan 02, 2025 - 15:50 UTC
Investigating
We are actively investigating. This is likely a network-wide issue.
Posted Jan 02, 2025 - 14:30 UTC
This incident affected: Arbitrum.