Security Notice: Geth DoS Vulnerability Mitigation
Incident Report for Alchemy
Resolved
Update: We have successfully upgraded all our nodes to the latest versions to address the recently identified Geth DoS vulnerability. Our infrastructure is now fully up to date and secured! 🚀

We continue to recommend that all users and node operators upgrade their clients if they haven’t already.
Posted Jan 31, 2025 - 05:08 UTC
Identified
A potential denial-of-service (DoS) vulnerability has been identified in a recent version of Geth: https://github.com/ethereum/go-ethereum/security/advisories/GHSA-q26p-9cq4-7fc2

Security hotfixes have been released to address the issue:
- Ethereum Geth: v1.14.13
- BNB Chain BSC: v1.4.17
- Optimism op-geth: v1.101411.6

We are actively upgrading our infrastructure to apply the latest version! We strongly recommend all users and node operators upgrade their clients as soon as possible to ensure the stability and security of their infrastructure!

For further details, please refer to the official releases from the respective networks!
Posted Jan 30, 2025 - 15:07 UTC