Stable Mainnet - Degraded Performance

Incident Report for Alchemy

Resolved

Nodes have recovered and services are healthy again.
Posted Jul 27, 2026 - 06:51 UTC

Identified

Nodes were unable to progress, team carried out a restart of the nodes and are seeing recovery and improved performance on requests. Actively monitoring.
Posted Jul 27, 2026 - 06:32 UTC

Investigating

A subset of requests on Stable Mainnet are experiencing degraded
Posted Jul 27, 2026 - 03:39 UTC
This incident affected: Stable.