Scroll Sepolia stalled

Incident Report for Alchemy

Resolved

Block production has started again and our nodes have caught up!
Posted Mar 14, 2025 - 15:11 UTC

Investigating

Block production on Scroll Sepolia is stalled - latest block mined was 8486730
This is a network wide incident: https://sepolia.scrollscan.com/
Posted Mar 13, 2025 - 14:15 UTC
This incident affected: Scroll.