Starknet Sepolia Degraded Performance

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Mar 20, 2026 - 22:15 UTC

Investigating

We are currently investigating a chain-wide issue affecting Starknet Sepolia. Some requests may experience degraded performance or failures. We are actively working with the Starknet team to resolve this and will provide updates as we learn more.
Posted Mar 20, 2026 - 19:40 UTC
This incident affected: Starknet.