Elevated Errors for Legacy Domain (alchemyapi.io)

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Oct 06, 2025 - 16:12 UTC

Monitoring

Services on the legacy alchemyapi.io domain have largely recovered and most traffic is now stable.

We’re still seeing minor inconsistencies for a small subset of traffic as DNS propagation continues, which can take anywhere from 30 minutes up to 24-48 hours depending on network caching.

To ensure continued reliability and avoid future interruptions, we strongly recommend updating integrations to use the new and fully supported domain: *.g.alchemy.com
Posted Oct 04, 2025 - 08:00 UTC

Investigating

We’re currently investigating elevated error rates for requests made to the legacy domain alchemyapi.io.

This issue affects traffic routed through that domain.

Requests sent to the new domain (*.g.alchemy.com) are not impacted and continue to perform as expected.
Posted Oct 04, 2025 - 05:45 UTC