Blast API Performance Degradation

Incident Report for Alchemy

Resolved

This incident has been resolved.
Posted Aug 13, 2025 - 08:54 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 13, 2025 - 08:39 UTC

Identified

We have identified the root cause of the issue and our engineering team has deployed a fix. We are now actively monitoring the system to ensure that everything is functioning as expected and remains stable.
Posted Aug 13, 2025 - 08:05 UTC

Investigating

We are currently observing a partial service degradation impacting the Blast API segment of our infrastructure across multiple chains. Affected systems are experiencing elevated latency, intermittent request failures, and block propagation delays across multiple regions. This may result in:

Authentication Failures: Users may be unable to log in due to timeouts or dropped authentication requests.

Block Lag: Delayed synchronization with the latest chain state, potentially impacting transaction visibility and confirmation times.
We will provide continuous updates as remediation progresses and full service performance is restored.
Posted Aug 13, 2025 - 08:01 UTC