Sui Mainnet - Service Degredation

Incident Report for Alchemy

Resolved

Our Sui nodes have recovered and are back to full performance.
Posted May 07, 2026 - 21:44 UTC

Update

We are continuing to investigate this issue.
Posted May 07, 2026 - 21:43 UTC

Investigating

We are investigating degraded performance on our SUI Mainnet nodes. Some requests are returning 503 responses. We are looking into this and will deploy a mitigation shortly.
Posted May 07, 2026 - 21:27 UTC
This incident affected: Sui.